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The Load Box User Interface System 

Introduction 

  
Introduction  The Load Box User Interface System, LUIS, is an engine simulator used to 

facilitate bench top engine control system hardware and software testing. The 

second generation LUIS system, LUIS Gen2, provides expanded capabilities 

from the original LUIS. 

   
LUIS Physical 

Description 
The LUIS is a bench top, PC controlled customizable load box. A standard 

LUIS Gen2 system configuration contains: 

 

¶ Main Module 

¶ Wavemaker Module 

¶ 2 Analog Modules 

¶ Switch Module 

¶ Resistive Loads Module 

¶ Injector and Application Specific Loads Module 

 

In addition, the user can request additional modules of each type depending 

on what is needed for their application. New modules are constantly being 

developed along with the ability to create custom modules for specific 

applications. Check with the GarTech engineering staff for additional 

information. 

 

This is a picture of a standard LUIS Gen2 system configuration. 

 

 

Continued on next page 
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Introduction, Continued 

 
LUIS Features The LUIIS Gen2 provides the following features. 

 

¶ Open and closed loop engine speed simulation 

¶ WaveMaker waveform generator, 8 channel arbitrary and 10 channel 

digital frequency outputs 

¶ LUIS Gen2 PC application allowing user complete control over I/O 

setup 

¶ Creation of configuration files to set up I/O for specific tests 

¶ Up to 128 16 bit DAC outputs 

¶ Up to 80 switch outputs 

¶ (1) 30A relay output 

¶ (4) 15A VBATT switched relay outputs 

¶ Up to 72 resistive load inputs 

¶ J1939 message simulation 

¶ Upgradable firmware 

Continued on next page 
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Chapter 1 ï Installation and Setup 

Overview 

  
LUIS 

Hardware 
The LUIS Gen2 has a main module that is connected to the PC via USB. 

Additional modules can be added including Wavemaker, Switch, Analog and 

Resistive Loads to customize the system to fit the userôs specific needs. 

 
LUIS Gen2 

Software 
The LUIS Gen2 comes with a graphical user interface for controlling all 

outputs as well as for setting up closed loop controls and J1939 simulation. 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Software   4 

Hardware 6 
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Section 1 ï Software 

Software 

 
Introduction  The LUIS Gen2 has a graphical user interface that runs in the Windows 

environment. The LUIS GUI is made up of a tab system with a toolbar 

specific to each tab. 

 
LUIS GUI 

Basic 

Environment 

This diagram and table describe the basic LUIS Gen2 GUI environment. 

 

 

 
 

 Description 

1 Main Menu and Quick Access Toolbar 

2 Tabs ï Options change based on the tab selected 

3 Workspace ï All windows display in this space.  

Continued on next page 
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Software, Continued 

 
Windows Activities within the LUIS Gen2 environment occur in windows which 

display in the workspace. Like any Windows 7 application, windows can be 

closed by clicking the X in the right-hand corner. By default, the Startup 

window displays when LUIS is started. This includes a list of recently used 

configurations, new help topics, news and the Gartech website. The LUIS 

software can be configured to not show the Startup Window by clicking the 

Defaults menu option on the Home tab and changing the No Startup Page 

option. 

 
Downloading 

and Installing 

Drivers 

Before the LUIS Gen2 hardware and software can be installed, the driver 

must be downloaded and installed. Go to www.gartechenterprises.com and 

visit the download center to download and then follow the on-screen steps to 

install. 

 
Downloading 

and Installing 

Software 

To install the LUIS Gen2 graphical user interface, visit the 

www.gartechenterprises.com download center and download the software. 

Follow the on-screen instructions to install the software. 
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Section 2 ï Hardware 

Overview 

 
Introduction  LUIS Gen2 provides the ability to run a standard hardware configuration or 

add additional modules as needed.  

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Ordering Hardware 7 

Setting Up a Standard LUIS Gen2 8 

Updating Devices 12 
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Ordering Hardware 

 
Gartech 

Contact 

Information  

All hardware can be ordered from GarTech Enterprises, Inc. 
 

Gartech Enterprises, Inc. 

3037 W. State Road 256 

Austin, IN 47102 

812-794-4796 

www.gartechenterprises.com 

info@gartechenterprises.com 

  
GarTech Part 

Numbers 
This table lists the part number and descriptions for the LUIS hardware. 

 

Part Number Description 

G01641-00 LUIS Gen2 Assembly: 

(1) Main Module 

(1) WavemakerIII Module 

(2) Analog Modules 

(1) Switch Module 

(1) Resistive Loads Module 

(1) Injector Loads Module 

G01800-00 Main Module and Wavemaker III Module 

G01801-00 Analog Module 

G01802-00 Switch Module 

G01803-00 Resistive Loads Module 

  
GarTech 

Wiring 

Harnesses 

The user can specify how they would like to connect the I/O from the LUIS 

hardware to the target application and a custom harness can be designed. 

  

http://www.gartechenterprises/
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Setting Up a Standard LUIS Gen2 

 
Introduction  The setup for a standard LUIS Gen 2 box is simple, requiring no special tools. 

Any ECM can be mounted to the top of the unit by moving the screw-in 

mounting pegs. It is then connected through a simple color-coded system. The 

unit communicates with the PC through a standard USB connection. 

  
Hardware 

Needed 
To set up the LUIS Gen2, the following hardware is required. 

 

¶ Standard LUIS 

¶ PC 

¶ Electronic Control Module 

¶ Wiring Harness 

¶ DC Power Cable 

¶ DC Power Supply 

¶ AC Power Cable 

¶ USB Cable 

¶ Loads Module Cable 

¶ Communications Cable 

 
Setting Up the 

Hardware 
This table outlines the physical connections required to set up the hardware to 

run a standard LUIS Gen2. 

 

Step Action 

1 Unscrew and configure the ECM pegs on top of the box, shown in 

Figure 1, to accommodate the ECM and mount the ECM on the 

pegs. 

2 Using the appropriate Wiring Harness, connect the Control 

Module to the LUIS Gen2 using the color coded ports on the back 

of the LUIS Gen2 box. 

4 Connect the 8 pin Unswitched Power Out connector port on the 

back of the LUIS Main Module 

5 Using the DC Power Cable, connect the LUIS Gen2 to the DC 

Power Supply using the Vbatt In port on the back of the LUIS 

Gen2, shown in Figure 2. 

Note: The DC Power Cable has a locking tab that must be 

depressed when disconnecting. 

Continued on next page 
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Setting Up a Standard LUIS Gen2, Continued 

  
Figure 1: 

Mounting the 

ECM 

This image illustrates the mounting pegs on the top of the LUIS Gen2. 

 

 

   
Figure 2: 

DC Power 

Connections 

This picture illustrates the DC Power connection between the LUIS and the 

DC power supply. 

 

 

Continued on next page 



Page 10 

 

Setting Up a Standard LUIS Gen2, Continued 

    
Setting Up the 

Hardware, 

Continued 

This table continues to outline the physical connections required to setup the 

hardware to run a standard LUIS Gen2. 

 

Step Action 

6 Using the Loads Module Cable, connect the Main Module to the 

Injector Specific Loads Module. 

Note: The cable is labeled Main Module End and Load Module 

End because it can be plugged in backwards. 

6 Using the AC Power Cable, show in Figure 3, plug the LUIS in. 

7 To complete the connection to the PC, plug a standard USB cable 

into the L-comm port on the back of the LUIS Gen2 and into a 

USB port on the PC. 

Continued on next page 
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Setting Up a Standard LUIS Gen2, Continued 

 
Figure 3:  

AC Power 

Supply 

This picture illustrates the AC power connection. 

 

 

 

 

 



Page 12 

 

Updating Devices 

  
Introduction  Gartech may periodically issue firmware upgrades for the modules. When 

upgrades are made available via the Gartech website, the user must download 

the file to the PC before downloading to the hardware. 

  
Updating 

Firmware 
This table outlines the steps for updating firmware. 

 

Step Action 

1 Download the appropriate firmware file from the Gartech website 

to the local PC. 

2 Ensure the LUIS Gen2 box is connected to the PC and running. 

3 From the LUIS Gen2 software Home tab, click the Devices icon. 

Result: The Devices window, shown in Figure 4, displays and the 

servers display in the Servers field. 

4 In the Servers field, select the correct server. 

Result: The devices available on that server display. 

5 In the Servers field, select the correct device. 

Result: The information for the device fills in on the right-hand 

side. 

6 Click the <Select File> button. 

Result: The Firmware File dialog box opens where the user can 

browse and select the file downloaded in Step 1. Once the file is 

selected and the user clicks <OK>, the dialog box closes and the 

name displays in the Firmware File field. 

7 Once the file has been selected and displays in the Firmware File 

field, click the <Download> button. 

Result: The status LED on the LUIS hardware will flash during the 

transfer then go out briefly while the hardware resets. A successful 

update results in the status LED turning back on. 

Continued on next page 
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Updating Devices, Continued 

  
Figure 4: 

Devices 

Window 

This graphic is an example of the Devices window. 
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Notes 
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Chapter 2 ï Navigating the LUIS Gen2 GUI 

Overview 

  
Introduction  The LUIS Gen2 graphical user interface provides a Windows based interface 

for communicating with the LUIS Gen2 box. The GUI is broken into 4 main 

tabs. All interaction takes place within windows in the workspace below these 

tabs. 

 
Main Menu The Main  menu is accessed by clicking the LUIS icon on the upper left-hand 

portion of the window. This menu provides the ability to create a new 

configuration file or open/save an existing file. It also provides a list of 

recently opened configuration files and an interface to print the details of a 

configuration file. 

 
Quick Access 

Toolbar 
The Quick Access Toolbar displays, by default, above the tabs. This feature 

provides quick shortcuts for saving a configuration as well as adding or 

modifying a window. This toolbar can be moved to display below the main 

toolbar by clicking the down-arrow and selecting Show Below the Ribbon. 

 
Tabs The tabs within the GUI are described below.  

 

Tab Description 

Home Provides the interface for working with 

configurations, interacting with hardware, 

managing tables and plug-ins, working with the 

WaveMaker application and setting defaults 

Tools Provides the interface for creating windows and 

building configurations 

View Provides an interface for navigating between open 

windows 

Help Provides on-line help 

Continued on next page 
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Updating Devices, Continued 

 
Hiding the 

Tabs 
At any time the tabs can be hidden to provide more space in the workspace. 

Right-click on any empty spot on a tab and select the Minimize the Ribbon 

option. The tab ribbon is hidden and the tab names display across a narrow 

bar. Clicking on these names opens the tab and clicking again closes it. To 

maximize the tabs, right-click on the narrow bar where the tab names appear 

and deselect the Minimize the Ribbon option. The ribbon can also be 

minimized/maximized from the drop-down arrow on the Quick Access 

Toolbar. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

 

Topic See Page 

The Home Tab 17 

The Tools Tab 23 

The View and Help Tabs 60 

Printing a Configuration File Summary 61 
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Section 1 ï The Home Tab 

The Home Tab 

 
Introduction  The Home tab is the tab that displays when the LUIS Gen2 software is 

opened. This tab provides the ability to update hardware, open the 

WaveMaker configuration, manipulate configuration files, set defaults as well 

as manage plug-ins and tables. 

 
Home Tab 

Toolbar 
This image shows the Home tab toolbar. 

 

 

 
Hardware The Hardware section of the Home tab toolbar provides the ability to do 

some basic updating to the hardware.  

 

Icon Description 

 

Opens the Server Management window where servers 

can be added and edited. 

 

For more information about servers, see Page 128. 

 

Opens the Devices window where the devices can be 

selected and new firmware can be downloaded. 

 

For more information about downloading firmware, see 

Page 12. 

Continued on next page 
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The Home Tab, Continued 

 
Hardware, 

Continued 
This table continues to outline the capabilities available from the Hardware 

section of the Home tab toolbar. 

 

Icon Description 

 

Sets the value of all the controls in the current 

configuration to their default 

 
Plug-Ins, 

Tables, 

Wavemaker 

and Datalink 

Simulation 

The Plug-Ins, Tables, WaveMaker and Datalink Simulation sections of the 

Home tab toolbar provide the ability to manage plug-ins, tables and 

waveforms as well as simulate datalink messages. 

 

Icon Description 

 

View currently installed plugins 

 

Opens the Table Management window where 

interpolation tables can be defined. 

 

For more information about working with 

interpolation tables, see Page 65. 

 

Opens the WaveMaker Management window 

where waveforms can be defined for use with the 

WaveMaker application. 

 

For more information about the WaveMaker 

application see Page 78. 

Continued on next page 
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The Home Tab, Continued  

 
Plug-Ins, 

Tables, 

Wavemaker 

and Datalink 

Simulation, 

Continued 

This table continues to outline the capabilities available from the Plug-Ins, 

Tables, WaveMaker and Datalink Simulation sections of the Home tab 

toolbar. 

 

Icon Description 

 

Opens the J1939 Datalink Sensor Simulation 

Management window where J1939 messages can be 

defined. 

 

For more information about J1939 Datalink Sensor 

Simulation see Page 108. 

 
Manipulating 

Configuration 

Files 

The Configuration  section of the Home tab toolbar provides the ability the 

work with configuration files. 

 

Icon Description 

 

Opens the Configuration File dialog box where a 

configuration can be selected and opened. 

 

Opens the Configuration File dialog box where a 

configuration file can be saved. 

Continued on next page 
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The Home Tab, Continued 

 
Manipulating 

Configuration 

Files 

This table continues to outline the capabilities available from the 

Configuration  section of the Home tab toolbar. 

 

Icon Description 

 

Clears the configuration. 

 

Sends the currently open configuration to the LUIS 

Gen2 hardware. 

 
Saves the current values of all controls as the new 

defaults. 

 
Attaching Files The Attachments icon on the Home tab toolbar opens the Attachments 

window where the user can attach a document, such as a wiring diagram, to 

the configuration. Once a file has been attached, the <Detach and Save> 

button can be used to save the file to the hard drive, and the <Open> button 

can be used to attempt to open the file using the default program for the file 

type. 

 

 

Continued on next page 
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The Home Tab, Continued 

 
Defaults The Defaults icon on the Home tab toolbar opens the Options window where 

defaults can be set for startup, configuration and interface. 

 

The Startup defaults allow the user to set whether or not a configuration is 

loaded as well as if the Startup Page should be displayed at startup. 

 

 
 

The Configuration  defaults allow the user to set what should happen after a 

configuration file is loaded as well as set a default configuration file. 

 

 

Continued on next page 
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The Home Tab, Continued 

 
Defaults, 

Continued 
The Interface defaults allow the user to set grid options for laying out 

controls on windows.  The F9 key toggles the snap option on and off. 
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Section 2 ï The Tools Tab 

The Tools Tab 

 
Introduction  Configuration files are built in user defined windows. The Tools tab provides 

the toolbar for adding windows in the workspace as well as tiles within 

windows. It also provides the interface for adding the desired controls to build 

the configuration. 

 
Definitions To easily work within the LUIS Gen2 GUI, it is necessary to understand some 

terminology. 

 

Term Definition 

Window A container in a configuration to which tiles 

can be added 

Tile A space within a window to which controls 

can be added and manipulated as a group. 

Every window has at least one tile. 

Digital Display A control that displays Engine Units, Counts 

and Millivolts digitally 

Gauge A control that displays values in a round or 

slider display 

Indicator A control that displays the status of resistive 

loads 

Text Panel A control that allows the user to add text to a 

configuration 

Switch A display that allows the user to add a 

momentary or toggle switch to the 

configuration 

Closed Loop Control A control that allows the user to create a 

simple closed loop engine speed model. This 

control is only available when using an ECM 

that outputs a public broadcast on the J1939 

datalink 

Dock The process of fixing the position of a 

window within the workspace 

Pin The process of fixing the position of a 

window within the workspace in a way that it 

ñwindow shadesò to the last docked position 

when not active 

Continued on next page 
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The Tools Tab, Continued 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Working with Windows 25 

Working with Tiles 40 

Working with Controls 48 
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Notes 
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Working with Windows 

 
Introduction  Windows are the ñcontainersò of tiles, and every window has at least one tile. 

Windows make up the base of a configuration file and display in the 

workspace. When a configuration file is saved, the position and status of all 

the windows are saved as well.  

 
Window Status 

and Positions 
Windows are placed within the workspace and can have one of four states: 

tabbed, dockable, dockable and floating or hidden. 

 

Status Description 

Tabbed When a window is tabbed, it remains in full screen 

mode and a tab with the windowôs name displays 

at the top of the workspace. Tabbed windows 

cannot be moved or resized. 

Dockable When a window is dockable, it can be docked to 

the top, bottom, left or right side of the workspace. 

The width or length of the window can be adjusted 

from the dockable position by hovering over the 

edge of the window until the cursor changes to the 

re-sizing cursor. 

Dockable and Floating When a window is dockable and floating it floats 

above the workspace until it is re-docked. When 

the window is floating, it can be moved around the 

workspace by dragging it by the title bar. It can 

also be resized by hovering over the edges until 

the cursor changes to the re-sizing cursor.  

Hidden When a window is hidden, it no longer displays in 

the workspace. A hidden window can be unhidden 

by selecting it on the View tab. 

 
Pinned / 

Unpinned 
When a window is pinned, it will remain in the docked position whether it is 

the active window or not. When a window is unpinned, (auto hide), the 

window will ñwindow shadeò into a tab in the last docked position when not 

active. A window can be switched between pinned and unpinned by clicking 

the push pin icon in the upper right-hand corner of the window. 

Continued on next page 
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Working with Windows, Continued 

 
Window Status In this image, the Main  window is currently docked to the left-hand side of 

the workspace and unpinned. It window shades to the left-hand side of the 

workspace when not active. The Frequency window is docked to the bottom 

of the workspace, and the rest of the windows are tabbed across the top of the 

workspace. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Adding 

Windows 
This table outlines the steps for adding a new window. 

 

Step Action 

1 Add a new window. 
 

Add Throughé Actioné 

Tools tab Click the Add Window  icon 

Quick Access Toolbar Click the Add Window  icon 

Workspace Right-click any empty spot in the 

workspace, not inside a tile, and 

select the Add Window Pane option 
  

Result: The Add Window Pane window displays, as shown in 

Figure 5. 

2 In the Dock Location section, select where the new window 

should be docked within the workspace. 

3 If the window should be unpinned, (window shade to the docked 

position when not active), select the Unpin checkbox. 

4 In the Window Name field, type the name for the window. 

5 In the Tile Layout  section, type the minimum number of columns 

and rows. 

6 When the window has been defined, click the <Add> button. 

Result: The window is added to the workspace, as shown in 

Figure 6. Note that every window automatically has one tile called 

Default. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 5: 

Add Window 

Pane 

This is an example of the Add Window Pane window. 

 

 

 
Figure 6: 

New Window 
This is an example of a new window added to the workspace that is docked to 

the top. 

 

 

Continued on next page 












































































































































































































































































































